Definire ritardo su invio email dopo reboot

Attenzione !I messaggi sul forum potrebbero essere modificati dal nostro staff. La data e l'ora dei messaggi potrebbe non essere quella di invio ma quella di moderazione da parte dello staff. Grazie per l'attenzione.

Home Forum Terminali operatore (Weintek) Definire ritardo su invio email dopo reboot

Stai visualizzando 5 post - dal 1 a 5 (di 5 totali)
  • Autore
    Post
  • #56410
    P91T
    Partecipante

    Ho un progetto su EasyBuilder con tutta una serie di allarmi con invio di email impostato correttamente. Quando trasferisco il nuovo programma, dopo un’assistenza, l’HMI si riavvia e poi invia tutte le email riguardanti allarmi già attivi in precendenza.

    E’ possibile disabilitare la funzione email per i primi 10 secondi ad esempio?
    Ho provato a cambiare il trigger in OFF->ON e cosi non mi invia la mail però cosi facendo gli allarmi che erano attivi prima del riavvio non li visualizzo più sull’oggetto di “visualizzazione allarmi”…

    #56414
    Sergio Bertana
    Amministratore del forum

    Puoi impostare per i singoli allarmi un ritardo di controllo sul reset del terminale (Screenshot).

    #56415
    P91T
    Partecipante

    Si ho visto però forse non ho spiegato bene il mio problema.

    L’allarme effettivamente è presente sia prima che l’hmi sia riavviato sia dopo. L’avviso dell’allarme via mail lo ho quindi già ricevuto e non vorrei che, quando riavvio l’hmi dopo una piccola modifica, mi re-invii di nuovo la mail di quel allarme… alzando il ritardo di controllo ciò che ottengo è solo un ritardo nell’invio della mail dopo il riavvio, ma la mail la invia lo stesso e non vorrei che lo facesse.

    #56445
    Sergio Bertana
    Amministratore del forum

    Purtroppo quello che ti serve non è realizzabile, il pannello memorizza l’avvenuto invio della mail su allarme in sue variabili interne che al riavvio si resettano e quindi trovando attivo l’allarme ne esegue il reinvio.

    #57274
    P91T
    Partecipante

    Scrivo qui la “soluzione” al problema cosicchè magari anche altri ne possano beneficiare.

    Sostanzialmente quello che ho fatto è stato realizzare una macro che andasse a popolare i vari gruppi di invio e-mail 10 secondi dopo l’avvio dell’hmi. In questo modo gli allarmi vengono visualizzati ma, al riavvio dell’hmi, non vengono inviati a nessuno poichè i gruppi di invio sono vuoti.

    NB. per eseguire i comandi di modifica dei contatti è necessario che sia aperta la pagina 78 (editor contatti) o comunque una pagina con l’elemento di EB per modificare i contatti; quindi è necessario inserire nella macro anche il cambio pagina.

Stai visualizzando 5 post - dal 1 a 5 (di 5 totali)
  • Devi essere connesso per rispondere a questo topic.