Eseguire trasferimento programma sorgente su target

Attenzione !I messaggi sul forum potrebbero essere modificati dal nostro staff. La data e l'ora dei messaggi potrebbe non essere quella di invio ma quella di moderazione da parte dello staff. Grazie per l'attenzione.

Home Forum Informazioni ambiente di sviluppo LogicLab Eseguire trasferimento programma sorgente su target

Questo argomento contiene 4 risposte, ha 1 partecipante, ed √® stato aggiornato da  Sergio Bertana 4 anni, 6 mesi fa.

Stai vedendo 5 articoli - dal 1 a 5 (di 5 totali)
  • Autore
    Articoli
  • #37322

    Anonimo

    Vorrei sapere se è possibile recuperare il programma che c’è dentro il PLC visto che ho perso quello su PC.

    #35244

    Sergio Bertana
    Amministratore del forum

    LogicLab permette di eseguire il download del programma sorgente sul dispositivo target, questa possibilità permette di avere una copia completa del programma direttamente sul sistema target. Collegandosi al target è possibile eseguire l’upload del programma presente nel sistema trasferendolo sul PC per poi effettuare il debug o per modificarlo.

    Naturalmente è prevista la possibilità di scegliere se si desidera trasferire oppure no il programma sorgente sul sistema target oltre ad una protezione tramite password del programma stesso, in assenza della password il file di programma sarà inutilizzabile.

    Dal menù Project -> Option è possibile aprire il pop up di definizione della password di protezione (Screenshot), la password è case sensitive, viene salvata nel progetto e non è visibile pertanto occorre tenerne nota.

    Dal menù Communication è possibile definire se si desidera oppure no trasferire il programma sorgente sul dispositivo target opzione Source code download (Screenshot). Questa opzione è attivata di default alla apertura del progetto, se non si desidera trasferire il codice sorgente sul target occorre ricordarsi di disabilitarla. Se l’opzione è attiva al termine del download del programma eseguibile nel target viene eseguito il download del programma sorgente.

    Per eseguire l’upload del progetto dal sistema target occorre connettersi al target, aprire LogicLab dal menù File -> Import project definire il tipo di dispositivo target e la modalità di connessione (Screenshot). Terminato l’upload viene richiesta la password e poi la cartella sul PC dove salvare il progetto. Il progetto verrà salvato nella cartella definita con un file di tipo ppjs con il nome originale che aveva e LogicLab si aprirà con il progetto attivo.

    #37323

    Sergio Bertana
    Amministratore del forum

    Come ho riportato nel messaggio precedente, l’operazione è possibile solo se hai scelto di eseguire il download del programma sorgente sul sistema target e se conosci la password di protezione dello stesso.

    Ricordo che per i moduli CPU SlimLine ARM7 per trasferire il programma sorgente sul target occorre avere inserito una memoria SD Card nell’apposito Slot micro-SD. In caso contrario durante l’upload apparirà un mesaggio di warning: Warning T8209:  No room for source file on the target e LogicLab abortirà il trasferimento (Vedi post).

    #38362

    Sergio Bertana
    Amministratore del forum

    Dalle versioni MPS046B*00 è stata inserita una memoria FLASH aggiuntiva per la memorizzazione del programma sorgente, questa memoria è presente su tutti i moduli CPU ARM7, anche i compact. Quindi non è più necessario disporre della memoria SD Card per poter trasferire il programma sorgente sul modulo CPU.

    #38398

    Sergio Bertana
    Amministratore del forum

    Con le nuove versioni di LogicLab è stata modificata la gestione del download del codice sorgente (ZIP del file di progetto con tutti i commenti) sul modulo target. Ora la scelta è impostata nel menù Project -> Options (Screenshot) ed è possibile scegliere tra 3 diverse opzioni.

    Never: Il codice sorgente non è mai scaricato sul sistema target.
    Before disconnession: Il codice sorgente viene scaricato quando si sconnette LogicLab dal sistema target.
    On PLC application download: Il codice sorgentye viene scaricato sul target ad ogni download applicazione.

    Naturalmente è possibile definire una password di protezione del codice. Di default è definita l’opzione di scaricare il codice sorgente ad ogni download applicazione sul sistema target.

    Consiglio di cambiare questa impostazione scegliendo di eseguire il download del codice sorgente alla sconnessione dal sistema, questo perché essendo il codice sorgente lo ZIP del file di progetto con tutti i commenti è un file di dimensioni molto più grandi rispetto al solo file applicazione. Questo allunga notevolmente il tempo necessario al download, e quando si sviluppa un programma ad ogni modifica si esegue il download per testarla ed è inutile perdere tempo nel download del sorgente.

Stai vedendo 5 articoli - dal 1 a 5 (di 5 totali)

Devi essere loggato per rispondere a questa discussione.