LogicLab crasha in manca di connessione internet

Attenzione !I messaggi sul forum potrebbero essere modificati dal nostro staff. La data e l'ora dei messaggi potrebbe non essere quella di invio ma quella di moderazione da parte dello staff. Grazie per l'attenzione.

Home Forum Informazioni ambiente di sviluppo LogicLab LogicLab crasha in manca di connessione internet

Questo argomento contiene 16 risposte, ha 3 partecipanti, ed è stato aggiornato da  Gianluca Raftacco 5 giorni, 2 ore fa.

Stai vedendo 15 articoli - dal 1 a 15 (di 17 totali)
  • Autore
    Articoli
  • #45744

    Gianluca Raftacco
    Amministratore del forum

    Con la versione della Suite “Pacchetto installazione suite IEC61131-3 Vers. 3.0.0 (LogicLab Ver. 5.8.0.17)”(Pck033i000) abbiamo aggiunto la visualizzazione di una pagina remota per le novità e le informazioni sul prodotto. A causa di un problema sul file il programma può andare in crash.

    Per risolvere il problema occorre scaricare questo FILE e decomprimerlo. Una volta estratto il file “welcome.html” dovrà essere copiato nella cartella di installazione di LogicLab dentro la cartella “/LogicLab5/templates” e sostituire il file originale.

    #45751

    Buongiorno, ho sostituito il file come descritto ma ora all’apertura LogicLab mi restituisce 2 errore script

    Primo errore

    ( Linea : 1

    Carattere: 1

    Errore: carattere non valido

    codice: 0

    URL: file:///c:/program%20files%20(x86)/elsist/logiclab/Common/script/common.js

    Secondo errore

    (

    Linea : 56

    Carattere: 3

    Errore: app non è definito

    codice: 0

    URL: file:///C:/Program%20Files%20(x86)/Elsist/LogicLab/LogicLab5/templates/welcome.html

    Se dalla pagina base di LogicLab schiaccio ctrl+f5 per aggiornalrla gli errori vengono di nuovo mostrati.

    #45761

    Gianluca Raftacco
    Amministratore del forum

    Alessandro, il file in questione lo ha copiato in una cartella di installazione di LogicLab 5.8.0.17 ?

    Scaricato dal nostro sito ?

    #45817

    Si certo, ho scaricato il file cliccando sul vostro link sopra ( FILE ) E l’ho copiato nella directory C:\Program Files (x86)\Elsist\LogicLab\LogicLab5\templates.

     

    Ho provato a disinstallarlo e reinstallarlo e a ricopiare il file ma da sempre lo stesso errore.

    #45826

    Gianluca Raftacco
    Amministratore del forum

    Ho provato sia su windows 7 che 10 con un installazione pulita di LogicLab e tutto funziona sia in presenza che in mancanza di connessione.

    Potrebbe chiamare qui in Elsist e cerchiamo di risolvere assieme il problema.

    Aggiornerò poi il topic con ulteriori informazioni utili nel caso ci siano altre modifiche.

    #45828

    Paolo
    Partecipante

    buongiorno,

    ho riscontrato lo stesso problema. In realtà non da subito ma qualche giorno dopo. Non me lo spiego.

    comunque ho risolto così:

    all’interno della funzione InitPage, ho aggiunto l’inizializzazione di  “var app”

    function InitPage()
    {
    <strong>var app = window.external;//riga aggiunta</strong>
    
    var fso = app.CallFunction("common.CreateObject", "Scripting.FileSystemObject")

    …ecc ..ecc

    gli errori sono scomparsi. la cronologia dei progetti è di nuovo visibile, ma il contenuto della pagina non credo sia completo.  Con ogni probabilita window.external non è l’oggetto adatto in questo contesto.

     

    #45831

    Gianluca Raftacco
    Amministratore del forum

    Salve Paolo !

    Potrebbe fare un prova ?

    Se con la sua correzione ora funziona potrebbe potrebbe provare a rimuovere la riga aggiunta e riprovare ?
    Avendo rimosso l’aggiunta funziona ancora tutto ? Cosa vede in entrambi i casi ?

    In presenza di connessione a internet dovrebbe vedere una pagina “LogicLab on web” mentre senza connessione no.

     

    #45832

    Paolo
    Partecipante

    Buongiorno Gianluca,

    ho provato come richiesto. se rimuovo la modifica ottengo un messaggio di errore.

    questo il contenuto del popup:

    Linea: 57

    Carattere 3

    Errore: ‘app’ non è definito

    Codice: 0

    url:     file:///C:Program Files (x86)/Elsist/Logiclab5/Logiclab5/templates/welcome.html

     

    #45834

    Gianluca Raftacco
    Amministratore del forum

    Buondì !

    Molto strano ! nel file che ho allegato la variabile app la ho definità all’interno della funzione prepareFrame.

    L’errore le viene mostrato dopo aver sovrascritto il file con quello che ho allegato io ? Che versione di windows sta utilizzando ? Era connesso a internet o offline ?

    Domani farò altri test !

    #45838

    Gianluca Raftacco
    Amministratore del forum

    Ho chiesto anche a Axel una spiegazione in merito al problema…. Vi tengo aggiornati.

    #45847

    Gianluca Raftacco
    Amministratore del forum

    Paolo , potrebbe dirmi che versione di internet explorer o EDGE ha installato sul computer dove le ha dato questo problema ?

    #45873

    Paolo
    Partecipante

    buongiorno Gianluca

    Microsoft EdgeHTML 17.17134
    Internet Explorer 11.407.17134.0

    Il sistema operativo è Windows 10 Home

     

    #45875

    Gianluca Raftacco
    Amministratore del forum

    Il problema si verifica anche con la connessione a internet presente ?
    Potremmo collegarci con TeamViewer per vedere il problema assieme ?

    Con LogicLab 4 funzionava tutto correttamente ?

    Qua trova una miniguida e l’installazione del tool per l’assistenza.

    Supporto remoto

    #45893

    Paolo
    Partecipante

    buongiorno Gianluca.

    TU: Potremmo collegarci con TeamViewer per vedere il problema assieme ?

    purtroppo in questi giorni non posso.

    TU: Con LogicLab 4 funzionava tutto correttamente ?

    Si.

     

    però posso fare un riepilogo.   la situazione è questa:

    1- avvio logiclab con pagina welcome originale
    assenza di connessione internet: segnalazione di errore nello script. proseguendo non viene caricata la cronologia dei progetti e non viene mostrata la pagina ‘logiclab on web’
    presenza di connessione internet: segnalazione di errore nello script. proseguendo non viene caricata la cronologia dei progetti e non viene mostrata la pagina ‘logiclab on web’

    2- avvio logiclab con pagina welcome modificata
    assenza di connessione internet:  non mostra la pagina ‘logiclab on web’ ma carica la cronologia dei progetti.
    presenza di connessione internet: non mostra la pagina ‘logiclab on web’ ma carica la cronologia dei progetti.

    ieri però mi sono accorto che ripristinato il file originale accedevo ai contenuti dinamici (logiclab on web). MA OGGI NO. E’ strano.
    forse avete cambiato il contenuto della pagina alla quale punta la pagina di benvenuto? http://logiclab.elsist.biz/it_IT/ ?

     

    #45906

    Gianluca Raftacco
    Amministratore del forum

    Buon giorno Paolo !

    Non abbiamo cambiato nulla nella pagina !

    Per  risolvere il problema appena recupero i file originali di LogicLab le mando una mail, cosi con i file di default il problema non dovrebbe ripresentarsi, in caso contrario interpelliamo di nuovo la Axel.

Stai vedendo 15 articoli - dal 1 a 15 (di 17 totali)

Devi essere loggato per rispondere a questa discussione.